设为首页加入收藏

微信关注
官方微信号:qingfeng7777777a
加关注获取每日精选资讯
股票入门欢迎您加入
广告服务联系我们网站地图

三个成交量选股公式

2019-05-18 22:50:45 技术分析知识库

使用说明:

这里发的指标均是通达信电脑版软件,手机软件有的可能不通用。

分别写三个公式:以MAVOL 5; MAVOL 35; MAVOL 135;为三根量线。

1:条件——个股30个以上交易日量柱均小于MAVOL 135线,某一日个股成交量异动,量柱穿越MAVOL135线时预警选股(如下图1)

MV5:=EMA(V,5);{5日均量线是主力启动线}

MV35:=EMA(V,35);{35日均量线是主力洗盘线}

MV135:=EMA(V,135);{135日均量线是资金异动线}

REF(EVERY(V<MV135,30),1) AND CROSS(V,MV135);

2:条件——个股20个以上交易日均满足 MAVOL 135>MAVOL 35 >MAVOL 5量 线,某一日个股MAVOL 5 量 线 上穿(即金叉)MAVOL 35量线时预警选股(如下图2)

 MV5:=EMA(V,5);{5日均量线是主力启动线}

MV35:=EMA(V,35);{35日均量线是主力洗盘线}

MV135:=EMA(V,135);{135日均量线是资金异动线}

REF(EVERY(MV135>MV35 AND MV35>V,20),1) AND CROSS(V,MV35);

 

3: 条件——当60日均线与120均线多头排列时, 个股 满足 MAVOL 35> MAVOL 135 > MAVOL 5 量 线,且量柱收阴线时预警选股(如下图3)

 

MV5:=EMA(V,5);{5日均量线是主力启动线}

MV35:=EMA(V,35);{35日均量线是主力洗盘线}

MV135:=EMA(V,135);{135日均量线是资金异动线}

EVERY(MA(C,60)>MA(C,120),60) AND EVERY(MV35>MV135 AND MV135>MV5,60);


 

指标源码:

 

AX:=PERIOD;

BL:=IF(AX=0,150,IF(AX=1,50,IF(AX=2,30,IF(AX=3,17,IF(AX=4,15,IF(AX=5,8,

IF(AX=6,3,IF(AX=7,2,IF(AX=8,50,IF(AX=9,3,1.3))))))))));

FM:=(EMA(CLOSE,1.414*9+1));

FCL:=IF(FM<=0.05,ABS(FM)+0.1,0);

DIF:=(EMA(CLOSE,9)-EMA(CLOSE,2*9+2))/(FCL+FM)*60*BL*4+260,COLORLIRED,LINETHICK1;

DEA:=EMA(DIF,9*0.75),COLORGREEN,LINETHICK1;

MACD:=2*(DIF-DEA)+200;

STICKLINE(MACD>200 AND MACD<REF(MACD,1),200,MACD,1,0),COLORGREEN;

STICKLINE(MACD>200 AND MACD>REF(MACD,1),200,MACD,1,0),COLORMAGENTA;

STICKLINE(MACD<200 AND MACD<REF(MACD,1),200,MACD,1,1),COLORLIGREEN;

STICKLINE(MACD<200 AND MACD>REF(MACD,1),200,MACD,1,1),COLORFF00FF;

DRAWBAND(DIF,RGB(200,50,55),DEA,RGB(100,400,100));

DRAWTEXT(CROSS(DIF,DEA),DIF*0.93,'B'),COLORYELLOW;

L1:=(CLOSE-LLV(LOW,11))/(HHV(HIGH,11)-LLV(LOW,11))*100*4+10;

K:SMA(L1,3,1),COLORGRAY;

D:SMA(K,3,1),COLOR38B0DE;

W:IF(K>REF(K,1),K,DRAWNULL),COLORMAGENTA,LINETHICK2;

MAXV:=CONST(HHV(VOL,100));

MAXD:=CONST(MAX(ABS(HHV(DIF,100)),ABS(LLV(DIF,100))));

BS:=MAXV/MAXD*1.5;

CC:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN*0.8/BS,DRAWNULL);

STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,CC,0,-1,-1),COLOR00C0C0;

AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

买盘:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+

(CLOSE-LOW)),VOL/2)),NODRAW;

买:买盘/10000,COLORRED,NODRAW;

卖盘:=IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,

0-AA*(HIGH-LOW),0-VOL/2)),NODRAW;

卖:卖盘/10000,COLORGREEN,NODRAW;

差额:(买盘+卖盘)/10000,COLORWHITE,NODRAW;

{BB:=(买盘+卖盘);}

三日净流入:SUM (差额,3),COLORMAGENTA,NODRAW;

STICKLINE(买盘>0 OR 卖盘<0 ,0,VOL/BS,2,0),COLORLICYAN;

STICKLINE(买盘>0,0,买盘/BS,2,0),COLORRED;

[!--temp.sitename--]声明:资讯来源于互联网,属作者个人观点,仅供投资者参考,并不构成投资建议。投资者据此操作,风险自担。