设为首页加入收藏

微信关注
官方微信号:qingfeng7777777a
加关注获取每日精选资讯
股票入门欢迎您加入
广告服务联系我们网站地图

文华财经鑫东财期货配资六个指标源码

2019-05-29 21:38:37 名家

文华财经鑫东财期货配资六个指标源码

HH:=HHV(HIGH,N);

LL:=LLV(LOW,N);

HH1:=BARSLAST((HH > REF(HH,1)));

LL1:=BARSLAST((LL < REF(LL,1)));

STICKLINE((HH1 < LL1),CLOSE,OPEN,COLORRED,0);

DRAWLINE((HH1 < LL1),HIGH,(HH1 < LL1),LOW,COLORRED);

STICKLINE((HH1 > LL1),CLOSE,OPEN,COLORBLUE,0);

DRAWLINE((HH1 > LL1),HIGH,(HH1 > LL1),LOW,COLORBLUE);

T:=IF(HH1>LL1,1,-1);

G:=IF(HH1>LL1,HH,LL);

DRAWLINE(T=1&&REF(T,1)=1,G,T=1&&REF(T,1)=1,REF(G,1),COLORCYAN);

DRAWLINE(T=-1&&REF(T,1)=-1,G,T=-1&&REF(T,1)=-1,REF(G,1),COLORRED);

DRAWSL(T=1,G,0,1,0,COLORCYAN);

DRAWSL(T=-1,G,0,1,0,COLORRED);

 

 

A50:EMA(CLOSE,49);

STICKLINE(CLOSE<MA50&&CLOSE>OPEN,OPEN,CLOSE,COLORCYAN,1);

STICKLINE(CLOSE<MA50&&CLOSE<=OPEN,OPEN,CLOSE,COLORCYAN,0);

DRAWLINE(CLOSE<MA50,HIGH,CLOSE>OPEN,CLOSE,COLORCYAN);

DRAWLINE(CLOSE<MA50,LOW,CLOSE>OPEN,OPEN,COLORCYAN);

DRAWLINE(CLOSE<MA50,HIGH,CLOSE<=OPEN,LOW,COLORCYAN);

STICKLINE(CLOSE>MA50&&CLOSE>=OPEN,OPEN,CLOSE,COLORYELLOW,1);

STICKLINE(CLOSE>MA50&&CLOSE<OPEN,OPEN,CLOSE,COLORYELLOW,0);

DRAWLINE(CLOSE>MA50,HIGH,CLOSE>=OPEN,CLOSE,COLORYELLOW);

DRAWLINE(CLOSE>MA50,LOW,CLOSE>=OPEN,OPEN,COLORYELLOW);

DRAWLINE(CLOSE>MA50,LOW,CLOSE<OPEN,CLOSE,COLORYELLOW);

DRAWLINE(CLOSE>MA50,HIGH,CLOSE<OPEN,OPEN,COLORYELLOW);

STICKLINE(HIGH>=HHV(CLOSE,ZQ)&&CLOSE>OPEN,OPEN,CLOSE,COLORRED,1);

STICKLINE(HIGH>=HHV(CLOSE,ZQ)&&CLOSE<=OPEN,OPEN,CLOSE,COLORRED,0);

STICKLINE(LOW<=LLV(CLOSE,ZQ)&&CLOSE>OPEN,OPEN,CLOSE,COLORGREEN,1);

STICKLINE(LOW<=LLV(CLOSE,ZQ)&&CLOSE<=OPEN,OPEN,CLOSE,COLORGREEN,0);

DRAWLINE(HIGH>=HHV(CLOSE,ZQ),HIGH,CLOSE>=OPEN,CLOSE,COLORRED);

DRAWLINE(HIGH>=HHV(CLOSE,ZQ),LOW,CLOSE>=OPEN,OPEN,COLORRED);

DRAWLINE(HIGH>=HHV(CLOSE,ZQ),HIGH,CLOSE<OPEN,LOW,COLORRED);

DRAWLINE(LOW<=LLV(CLOSE,ZQ),HIGH,CLOSE<=OPEN,LOW,COLORGREEN);

DRAWLINE(LOW<=LLV(CLOSE,ZQ),HIGH,CLOSE>OPEN,CLOSE,COLORGREEN);

DRAWLINE(LOW<=LLV(CLOSE,ZQ),LOW,CLOSE>OPEN,OPEN,COLORGREEN);

 

 

 

Y1:=(MA(CLOSE,2)+MA(CLOSE,3)+MA(CLOSE,4)+MA(CLOSE,5))/4;

Y2:=EMA(Y1,5);

Y3:=EMA(Y2,3);

YY:EMA(Y3,N1),COLORRED;

Z1:=(MA(CLOSE,9)+MA(CLOSE,6)+MA(CLOSE,7)+MA(CLOSE,8))/4;

Z2:=EMA(Z1,5);

Z3:=EMA(Z2,3);

ZZ:EMA(Z3,N2),COLORGREEN;

VERTLINE( CROSS( YY,ZZ ) , COLORRED);

VERTLINE( CROSS( ZZ, YY), COLORGREEN);

DRAWTEXT( CROSS( YY,ZZ ), ZZ, '▲');

DRAWTEXT( CROSS( ZZ,YY ),YY , '▽');

DRAWLINE(YY>=ZZ,HIGH,YY>=ZZ,OPEN,COLORRED);

DRAWLINE(YY>=ZZ,LOW,YY>=ZZ,CLOSE,COLORRED);

DRAWLINE(YY<ZZ,HIGH,YY<ZZ,CLOSE,COLORCYAN);

DRAWLINE(YY<ZZ,LOW,YY<ZZ,OPEN,COLORCYAN);

DRAWLINE(ABS(YY-ZZ)<0.00001,LOW,ABS(YY-ZZ)<0.00001,OPEN,COLORWHITE);

DRAWLINE(ABS(YY-ZZ)<0.00001,HIGH,ABS(YY-ZZ)<0.00001,OPEN,COLORWHITE);

STICKLINE((YY-ZZ)>0.00001,OPEN,CLOSE,COLORRED,1);

STICKLINE((YY-ZZ)<-0.00001,OPEN,CLOSE,COLORCYAN,1);

 

M1:MA(C,5);

M2:MA(C,30);

M3:MA(C,60);

DRAWLINE(M1>M2 && M2<M3,L,M1>M2 && M2<M3,H,COLORMAGENTA);

STICKLINE(M1>M2 && M2<M3,O,C,COLORMAGENTA,1);

DRAWLINE(M1<M2 && M2>M3,L,M1<M2 && M2>M3,H,COLORGREEN);

STICKLINE(M1<M2 && M2>M3,O,C,COLORGREEN,1);

DRAWLINE(M1>M2 && M2>M3,L,M1>M2 && M2>M3,H,COLORRED);

STICKLINE(M1>M2 && M2>M3,O,C,COLORRED,1);

DRAWLINE(M1<M2 && M2<M3,L,M1<M2 && M2<M3,H,COLORBLUE);

STICKLINE(M1<M2 && M2<M3,O,C,COLORBLUE,1);

 

 

C:=CLOSE;

H:=HIGH;

L:=LOW;

O:=OPEN;

DUO:EMA(C,3),COLORWHITE;

KONG:EMA(C,5),COLORBLUE;

JH:EMA(KONG,5),COLORYELLOW;

VARF1:=COUNT(CROSS(DUO,JH),2)=1;

VARF2:=COUNT(CROSS(KONG,JH),2)=1;

ZAI:=COUNT(VARF1 && VARF2,2)=2;

VV2:=REF(CLOSE,1);

VV3:=SMA((CLOSE-VV2),6,1)/SMA(ABS(CLOSE-VV2),6,1)*100;

VF1:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;

VARA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;

VARB:=EMA(0.667*REF(VARA,1)+0.333*VARA,5);

VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;

VAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5;

VAR2:=REF(VAR1,1);

VAR3:=SMA(MAX(VAR1-VAR2,0),10,1)/SMA(ABS(VAR1-VAR2),10,1)*100;

HY3:=IF(COUNT(VAR3<20,5)>=1 && COUNT(VAR1=LLV(VAR1,10),10)>=1 && CLOSE>=OPEN*1.038 && VOL>MA(VOL,5)*1.2,1,0);

S:=MA(VOL,5)/MA(VOL,60);

A:=MA(S,5);

BIAS:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100;

F:=MA(S,121);

RSV:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;

K:=SMA(RSV,15,1);

D:=SMA(K,15,1);

J:=3*K-2*D;

LC:=REF(CLOSE,1);

RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

S1:=IF((J<11 && BIAS>-11 && CROSS( S,F) && (S-F)>0.010),2,0);

MID:HHV(MA(H,13),13),COLORRED;

QS:LLV(MA(H,13),1),COLORGREEN;

DRAWLINE(DUO>=QS,HIGH,DUO>QS,LOW,COLORRED);

STICKLINE(DUO>=QS,OPEN,CLOSE,COLORRED,0);

DRAWLINE(DUO<QS,HIGH,DUO<QS,LOW,COLORBLUE);

STICKLINE(DUO<QS,OPEN,CLOSE,COLORBLUE,0);

[!--temp.sitename--]声明:资讯来源于互联网,属作者个人观点,仅供投资者参考,并不构成投资建议。投资者据此操作,风险自担。

»延伸阅读
»延伸阅读